Skip to main content

ERA - Not linking

Answered

Comments

5 comments

  • Gillian

    Hi Matt, it sounds like this is more specific to your account, so I'm going to have a member of our Insurance Specialist team reach out to you to assist.

    Comment actions Permalink
  • Rick Morris

    I'm having this problem - we are new and the first ERA to come thru was Blue Cross Florida and auto posted last week but not this week, I can see payments and claims on Availity - any ideas?

     

    Comment actions Permalink
  • Gillian

    Happy to help, Rick. BCBS is having some delays in sending ERAs due to the pandemic. If you still haven't received the ERA, please reach out through the ? bubble so the Success team can investigate. 

    Comment actions Permalink
  • Alexsandra K. Walker

    I am having this issue as well with BCBS. Are most people still seeing delays in receiving their ERAs from BCBS? If not, I need assistance with my account. I used to receive ERAs with now issues. Cigna still works fine, BCBs does not for some reason....again, this used to work earlier this year. Maybe it's the pandemic, maybe there are technical issues. Any help would be greatly appreciated. 

    Comment actions Permalink
  • Ruth

    Hi Alexsandra, as Gillian mentioned, the best way to figure out why you're not getting your ERAs through SimplePractice is by reaching out to our Insurance Team. To do so, you can click the ? icon to the bottom right of your account > Get Help. You can also click here to submit an email Help Request!

    Comment actions Permalink

Please sign in to leave a comment.