Skip to main content

ERA/Emails

Answered

Comments

7 comments

  • Rick Morris

    This is a pattern since we moved to Simple Practice - i know it takes time for the ERA's to get connected and approved - but i had 1 BCBS ERA post on 4/10/20 and none since but many payments from them, also same with Cigna - Every time i raise the concern with SP i have to start the process from the beginning and they want the documents to prove to Clearinghouse there is a problem - i don't know if SP actually keeps records of Customer service efforts but we should not have to start the whole process over each time we communicate a problem when its the same problem never fixed - i requested a phone call from SP to discuss solutions and never received a call - I still have my Therapy Appointment account active and seriously considering transitioning back to TA from SP but don't want the burden to be placed on my clients - we have multiple staff and multiple locations and are in need of MUCH BETTER CUSTOMER SUPPORT!

    Comment actions Permalink
  • Rick Morris

    for a strange reason we received ERA's in SP today for Blue Cross - no prior just all of a sudden one shows up today. We are thankful - hoping this is a consistent pattern. Thanks SP.

    Comment actions Permalink
  • John Amendt

    I've had the same problem the last couple of weeks. I've been with SP since 2016 and this is the first time that we have had this problem. The first week the ERA's didn't show up until about 6 days later. The second week it was about a 3 day delay. This week it is still about 2 days and still waiting. I'm still attributing it to the changes with going to teletherapy, but I do hope it gets resolved soon as I have employees that I can't pay until I know how to divide up the payments when they come in. I know customer service can sometimes be slow with SP, but it is a highly versatile program and they are always trying to make it better with improvements to the program. I would encourage you to hang in there and give it at least a couple of weeks to see if they can get the ERA's to come at the same time as the payments.

    Comment actions Permalink
  • Rick Morris

    Thanks John. We did evaluate SP for a year before switching and do agree they have a lot of good things happening. Strangely we received a few new ERAs today from a variety of payers. I’m thinking it may have more to do with the clearinghouse than with SP. thanks for the response.

    Comment actions Permalink
  • Rick Morris

    I happily report ERA's are flowing in and posting automatically from nearly all our insurance companies - i don't know what the problem was the past 3 weeks but happy as can be right now!

    Comment actions Permalink
  • Brian Mueller

    I am new to Simple Practice but have experienced the same problems.  I have received check payments from United Healthcare, with whom I am enrolled for ERAs, but have not received the corresponding ERAs, so it looks like I have to go in and manually add all of these payments.  Is there any easier way of doing this?  

    Comment actions Permalink
  • Ruth

    Hi Everyone - Sorry I'm late to the game, but I'm happy to hear some of your Payment Reports have resumed posting! 

    To offer you some context, we've noticed some delays in Payment Report delivery during the pandemic. 

    If you find that you're still not getting your Payment Reports on time, please submit a Help Request here: SimplePractice Help Request Form. Submitting a Help Request is the quickest way to get in touch with our Customer Success Group. 

    Although we're periodically monitoring the Community Forum and plan on improving our response times to questions posed here, this is also a place for customers to exchange ideas and engage with one another on how to best use our platform. Thank you all for contributing to this post and acting as resources for each other in the meantime.

    Comment actions Permalink

Post is closed for comments.